Панфилов Евгений
Вариант 02
В каждой лабораторной нужно ответить на контрольные вопросы
ЛАБОРАТОРНАЯ РАБОТА 1
Тема: Первое приложение на DELPHI
Цель работы: Ознакомиться с основными приемами работы в среде DELPHI
Задание 1. Выполните последовательно следующие действия
1. Запустите Delphi. (Пуск → Программы → Borland Delphi 5) 
2. Выберите в Палитре компонентов закладку Standard. 
3. Перенесите с Палитры компонентов на форму компоненты TLabel и TButton. Для этого поочередно подводите курсор мыши к компонентам, читая подсказки, до тех пор, пока не появится Label. Выберете его, нажав левую кнопку мыши, а затем переместите указатель на форму и нажмите еще раз на кнопку мыши. Помещенный на форму компонент будет иметь имя Label1. 
4. Проделайте то же самое, только с компонентом TButton. 
5. Напишите обработчик события Button1Click. Для этого выберите на форме Button1 и щелкните на него дважды. Вы окажетесь в окне редактирования. Приведите обработчик события нажатия кнопки к следующему виду: 
procedure TForm1.Button1Click(Sender: TObject);
begin
___Label1.Caption:= 'Здравствуй, мир!';
end;
При нажатии на кнопку вызывается обработчик события Form1.Button1Click(Sender: TObject), в котором мы меняем свойство Caption у объекта Label1.
6. Создайте новый каталог с именем MyProject. Для этого выполните команду главного меню File → Save Project As и с помощью пиктограммы “Новый каталог” создайте новый каталог. Сохраните проект в созданном каталоге, при этом предлагается сохранить два файла (с расширением pas и prj). Можно набирать произвольные имена. 
7. Запустите на выполнение созданное Приложение. Для этого выберете в главном меню пункт Run → Run, или нажмите клавишу F9. 
8. Нажмите на кнопку в запущенном Приложении и посмотрите, что из этого получилось. Закройте Приложение. 
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9. Поместите на форму компонент TEdit (см. п.3) и TButton. 
10. Приведите обработчик события нажатия кнопки Button2 к следующему виду (вызов обработчика см. в п.5): (Переключение между формой, инспектором объектов и окном редактирования - F12). 
procedure TForm1.Button2Click(Sender: TObject);
begin
___Label1.Caption:= Edit1.Text;
end;
11. Измените свойство Edit1.Text на “Привет, студент!!!”. Для этого выберете на форме объект Edit1. Перейдите в Object Inspector, в закладке Properties найдите свойство Text и замените его. 
12. Запустите на выполнение ваше Приложение. Попробуйте нажимать кнопку, вводя разное значение в строку редактирования. Закройте Приложение. 
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13. Добавьте компоненты TLabel и TButton. Установите свойство объекта Label2.Caption равным 1 (см. п.3). 
14. Приведите обработчик события нажатия кнопки Button3 к следующему виду (см. п.5): 
procedure TForm1.Button3Click(Sender: TObject);
Var i: integer;
Begin
___i:= StrToInt(Label2.Caption);
___Label2.Caption:= IntToStr(i+1);
end;
[bookmark: r1]{ IntToStr, StrToInt – функции, преобразующие целый тип в строковый и строковый в целый соответственно }
15. Разместите на форме все кнопки вертикально, друг под другом. Выделите все кнопки и выровняйте их размеры и положение с помощью команд Edit → Size и Edit → Align. 
16. Сохраните и запустите приложение из среды. Проверьте работоспособность всех кнопок формы. 
Должно получиться подобное приложение
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	Рисунок 1.1  Работа приложения
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Задание 2.
1. Создайте новое приложение (команда главного меню File → New → Application). 
2. Добавьте на форму три компонента TButton, три компонента TLabel и один компонент TEdit. 
3. Выравняйте размеры и положение компонентов на форме. Измените названия кнопок и текст в строке редактирования. Строка редактирования должна содержать следующую информацию: название группы и последние две цифры шифра студента. Форма может выглядеть примерно таким образом. 
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	Рисунок 1.2  Примерный вид формы


4. 
5. Запрограммируйте действие каждой из кнопок. При нажатии на кнопку в соответствующей метке должны появляться фамилия, имя и отчество студента. 
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	Рисунок 1.3  Работа приложения


Контрольные вопросы
1. Назовите основные составляющие среды DELPHI и их назначение. 
2. Назовите состав и назначение пунктов главного меню системы. 
3. Каково назначение Инспектора объектов? 
4. Из каких основных файлов состоит проект приложения? 
5. Как производится размещение, перемещение, изменение размеров компонентов на форме? 
6. Как запустить приложение на выполнение из среды DELPHI? 
7. Поясните назначение и основные свойства и события компонентов формы приложения. 
8. Поясните тексты методов приложения. 
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Тема: Определение нажатой клавиши и нажатого символа.
Цель работы: Ознакомиться с основными клавиатурными событиями визуальных компонентов.
Задание 1. Выполните следующие действия
1. Разместите на форме 6 объектов типа Label и одну кнопку с растровым изображением (компонент BitBtn на закладке Additional палитры компонентов). Установите у кнопки свойство Kind равным bkClose. Тогда при нажатии на эту кнопку приложение будет закрываться.
2. При создании одинаковых по размеру объектов пользуйтесь буфером обмена или командой Edit → Size. Для выравнивания положения объектов на форме используйте команду Edit → Align.
3. Для всех объектов типа Label установить свойство AutoSize равным False, свойство Aligment – taCenter. Для меток слева установите нужные свойства Caption, Font. Для меток справа удалите свойство Caption, измените свойство Font по своему усмотрению.
4. Для всех объектов типа ТLabel оформите границы, используя такие декоративные элементы, как фаски (компонент ТBevel на закладке палитры компонентов Additional). У объектов типа ТBevel установите значения свойств Shape и Style.
В результате окно будет выглядеть примерно так
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	Рисунок 2.1  Примерный вид окна



5. Установите для формы значение свойства KeyPreview равным True для того, чтобы форма могла обрабатывать события для клавиатуры.
6. В процедуре обработки события OnKeyDown для формы необходимо выполнить следующие действия. Показать значение переменной Key (код виртуальной клавиши) в качестве нажатой клавиши. Для преобразования кода в строковую переменную используйте функцию IntToStr. Проверить были ли нажаты клавиши Shift, Alt, Ctrl (принадлежат ли элементы ssShift, ssAlt, ssCtrl множеству Shift, которое передаётся процедуре в качестве параметра). Создать строку из комбинации нажатых клавиш (например, Shift+Alt+Ctrl, если были нажаты все три клавиши) и поместить её на форму в соответствующее место.
Например, для проверки нажатия клавиши Alt можно использовать следующий код
procedure TForm1.FormKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
begin
if ssAlt in Shift then Label6.Caption:= 'Alt';
end;

7. Процедура обработки события OnKeyPress получает значение параметра Key, равное символу ASCII. Для отображения символа в объекте Label2 используйте Label2.Caption:= Key.
8. В процедуру обработки события формы OnKeyUp добавьте операторы очистки заголовков объектов типа Label из среднего столбца. Например, Label2.Caption:= ''. 
При нажатии клавиши с буквой A (англ. раскладка) будет отображаться нажатый символ «а» и код нажатой клавиши 65.
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	Рисунок 2.2  Работа приложения



При нажатии комбинации клавиш Shift + A (англ. раскладка) будет отображаться нажатый символ «A», код нажатой клавиши 65 и название клавиши Shift.
	[image: Image148.gif]

	Рисунок 2.3  Работа приложения
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Задание 2.
1. Добавьте на форму еще один компонент ТLabel. При нажатии определенной комбинации клавиш в метке должны появляться название группы и фамилия студента. Комбинация клавиш выбирается по последней цифре шифра студента.
1. Ctrl + Shift 
2. Alt + Q 
3. Ctrl + 5 
4. Alt + 5 
5. Shit + 1 
6. Shift + L 
7. Shift + B 
8. Ctrl + 9 
9. Alt + 9 
10. Alt + Shift 
Контрольные вопросы
1. Поясните назначение и основные свойства и события компонентов формы приложения. 
2. Поясните тексты методов приложения. 
3. Какие события используются для получения комбинации нажатых или отпущенных клавиш? 
4. Какое событие позволяет определить нажатый символ? 
5. Для чего используется компонент ТBevel? 
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Тема: Создание главного меню.
Цель работы: Научится использовать в приложении главное меню.
Задание 1. Выполните следующие действия
1. Поместите на форму компонент MainMenu (закладка Standart на Палитре компонентов). Вызовите Дизайнер Меню, дважды щелкнув мышкой по компоненту на форме. Затем создайте меню как показано на рисунке 85. Для создания подменю можно воспользоваться командой Create SubMenu в контекстном меню, которое вызывается правой кнопкой мыши. После разработки закройте Дизайнер Меню. В верхней части формы теперь можно видеть разработанное меню.
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	Рисунок 3.1  Вид меню при конструировании


2. 
3. При нажатии на отдельный пункт меню должно появляться информационное окно, которое содержит значение соответствующей характеристики формы. Двойной щелчок по пункту меню дает заготовку обработчика. Например, нажатие пункта Ширина можно обработать следующим образом
procedure TForm1.N2Click(Sender: TObject);
var s: string;
begin
___s:= format('Width %d', [width]);
___ShowMessage(s);
end;
4. Аналогичным образом обработайте остальные пункты меню, создавая информационные окна с соответствующей информацией о форме.
5. Для быстрого вызова команд можно использовать так называемые быстрые клавиши. Для этого для каждого пункта меню установите свойство ShortCut, выбрав значение из списка. При этом нужно следить, чтобы быстрые клавиши не повторялись во избежание коллизий.
6. Поместите на форму компонент ImageList (закладка Win32 на Палитре компонентов). Дважды щелкнув на компонент, можно вызвать редактор этого компонента. Используйте кнопку Add, чтобы добавить иконки (файлы с расширением ico). Можно использовать любые готовые иконки либо создать их самостоятельно. Для этого нужно вызвать редактор изображений (пункт главного меню Tools → Image Editor). Далее создайте новое изображение File → New → Icon file ( .ico). Нарисуйте икону, используя различные цвета и инструменты на панели. Сохраните иконку в свою директорию. Рекомендуется добавить в ImageList 5-6 различных иконок.
7. Выделите компонент MainMenu1 и установите свойство Images равным ImageList1. После этого для каждого пункта меню установите свойство ImageIndex, выбрав из списка нужную иконку. Меню может выглядеть так.
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	Рисунок 3.2  Вид меню


8. 
9. Для каждого из пунктов меню Размеры установите свойство Break равным mbBarBreak. Запустите приложение, проверьте его работу.
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Задание 2.
1. Создайте новое приложение. Добавьте на форму компонент MainMenu и приведите его к следующему виду. 
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	Рисунок 3.3  Вид меню


2. 
3. Для каждого пункта меню укажите иконку и горячую комбинацию клавиш. 
4. Каждый пункт меню запрограммируйте так, чтобы при вызове появлялось информационное окно с соответствующей информацией. При вызове пункта меню «Выход» приложение должно завершать свою работу. 
Контрольные вопросы
1. Поясните назначение и основные свойства и события компонентов формы приложения. 
2. Поясните тексты методов приложения. 
3. Как вызвать Дизайнер Меню? 
4. Как создать подменю? 
5. Каким образом можно поместить иконки для пунктов меню? 
6. Как установить быстрые клавиши для пунктов меню? 
7. На что влияет свойство Break пункта меню? 
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Тема: Создание простейшего текстового редактора.
Цель работы: Освоить использование основных диалоговых компонентов.
Задание 1. Выполните следующие действия
1. Поместите на форму компонент ТMainMenu. Структура меню должна иметь вид: 
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	Рисунок 4.1  Структура меню


2. 
3. При выборе пункта Автор должно появляется информационное окно с данными автора. При выборе пункта Выход приложение завершает свою работу. 
4. Запустите приложение. Проверьте работу приложения.
5. Поместите на форму компонент всплывающее меню – ТPopupMenu. Всплывающее меню появляется в работающем приложении при щелчке правой кнопкой мыши по форме. Это меню должно содержать пункты Автор, Сохранить, Выход с назначенными им клавишными эквивалентами для быстрого выполнения пунктов меню. 
6. Для того, чтобы форма могла использовать объект PopupMenu1, определите значение свойства PopupMenu из выпадающего списка для формы. 
7. Для создания обработчиков событий, поступающих от всплывающего меню, для пункта Автор определите значение события OnClick, выбрав из раскрывающегося списка название процедуры, которое использовалось для пункта Автор главного меню. Аналогичным образом определите значение события OnClick для пункта Выход. Таким образом, события для разных объектов будут совместно использовать один и тот же обработчик события. 
8. Запустите приложение и проверьте работу всплывающего меню.
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9. Поместите на форму компонент ТLabel. Присвойте свойству Caption значение - Имя файла. 
10. Поместите на форму компонент ТEdit под компонентом ТLabel. Очистите значение свойства Text объекта Edit1. В дальнейшем здесь будет имя редактируемого файла. 
11. Поместите на форму объект Memo (многострочный редактор), измените его размер и выровняйте визуальные компоненты, расположенные на форме, используя в главном меню Delphi Edit → Align. Уберите у свойства Lines объекта Memo1 его значение. Установите вертикальную и горизонтальную полосы прокрутки, используя свойство ScrollBar объекта Мемо1. 
Теперь приложение будет выглядеть так
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	Рисунок 4.2  Вид приложения



12. Поместите на форму компоненты TOpenDialog и TSaveDialog, расположенные на закладке Dialogs палитры компонентов. Для объектов OpenDialog1 и SaveDialog1 определите свойства DefaultExt, Filter, FilterIndex, Title, которые имеют следующий смысл
		Свойство
	Назначение

	FileName
	Содержит маршрут поиска и выбранный файл при успешном завершении диалога.

	Filter
	Используется для фильтрации (отбора) файлов, показываемых в диалоговом окне.

	InitialDir
	Содержит имя начального каталога.

	DefaultExt
	С помощью свойства DefaultExt формируется полное имя файла, если при ручном вводе пользователь не указал расширение. В этом случае к имени файла прибавляется разделительная точка и содержимое этого свойства.

	Title
	Содержит заголовок диалогового окна.





13. 
14. Для активизации диалогового компонента OpenDialog используйте его метод Execute в обработчике события OnClick для пункта меню Открыть. Если пользователь закрывает диалоговое окно, щелкнув на кнопке OK, то функция Execute возвращает значение True и содержимое файла загружается в многострочный редактор.
Например,
procedure TForm1.N2Click(Sender: TObject);
begin
___If OpenDialog1.Execute then
______Memo1.Lines.LoadfromFile(OpenDialog1.FileName);
end;
Тогда при выборе пункта Открыть будет открываться такое окно
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	Рисунок 4.3  Диалоговое окно открытия файла



15. Для проверки существования файла используйте функцию FileExists, поскольку открываться может только уже существующий файл. 
16. Перед загрузкой файла в компонент Memo необходимо очистить его. Это можно сделать, используя метод Memo1.Clear для очистки окна Memo1 
17. Имя загружаемого файла сохраняется в свойстве FileName компонента OpenDialog и должно отобразиться в строке редактирования под надписью «Имя файла». 
18. Для обработки события OnClick пункта Открыть всплывающего меню подключите ту же процедуру, что используется для пункта Открыть главного меню. 
19. Аналогичные действия проделайте и с пунктом Сохранить, при этом проверку на существование файла делать не нужно, поскольку если такой файл не существует, то приложение автоматически его создаст. 
20. Содержимое редактора Мемо1 загружается в файл методом SavetoFile. При сохранении файла в диалоговом окне должно предлагаться имя, заданное в компоненте TEdit. 
21. Для того, чтобы курсор установился в окно редактора, необходимо после загрузки файла в окно редактора установить значение свойства ActiveControl равным Мемо1. Поэтому в процедуру обработки события OnActivate формы добавьте следующий оператор:
Form1.ActiveControl:= Memo1;
22. Запустите приложение и проверьте его работу.
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23. Создайте фильтры файлов, используя встроенный редактор свойства Filter диалоговых компонентов (вариант выбирается по последней цифре шифра студента)
1. исполняемые файлы (exe), все файлы, текстовые файлы (txt) 
2. doc-файлы, все файлы, pas-файлы 
3. asm- файлы, исполняемые файлы (exe), bat- файлы 
4. все файлы, bmp-файлы, текстовые файлы (txt) 
5. pas-файлы, cpp-файлы, все файлы 
6. исполняемые файлы (exe), все файлы, текстовые файлы (txt) 
7. doc-файлы, все файлы, pas-файлы 
8. asm- файлы, исполняемые файлы (exe), bat- файлы 
9. все файлы, bmp-файлы, текстовые файлы (txt) 
10. pas-файлы, cpp-файлы, все файлы 
Контрольные вопросы
1. Поясните назначение и основные свойства и события компонентов формы приложения. 
2. Поясните тексты методов приложения. 
3. Какие компоненты используются для организации диалога при сохранении и открытии файлов? 
4. Какой метод активизирует диалоговые компоненты? 
5. Что такое контекстное меню? 
6. ККак осуществляется совместное использование одного обработчика различными компонентами? 
[bookmark: L5]ЛАБОРАТОРНАЯ РАБОТА 5
Тема: Создание заставки текстового редактора. Создание таймера.
Цель работы: Научиться использовать различные виды форм.
Порядок выполнения работы:
Создание заставки
1. Откройте ранее созданный текстовый редактор. Создайте с помощью команды меню File → New → Form новую форму Form2. Эта форма будет использоваться в качестве заставки перед запуском главного окна приложения. Для новой формы удалите значение свойства Caption. Свойству BorderStyle присвойте значение bsNone (результат увидите только при запуске программы). Для удаления кнопок минимизации, максимизации формы и системного меню установите у свойства BorderIcons значения подсвойств biMinimize, biMaximize, biSystemMenu равными False (результат увидите только при запуске программы).
2. Также для новой формы свойство Enabled установите равным False для того, чтобы заблокировать обработку событий и лишить возможности пользователя управлять окном с помощью клавиатуры или мыши.
3. Сохраните проект, определив имя второго программного модуля проекта.
4. Выполните команду Project → Options. В предложенном окне выберите закладку страницы Forms. Переместите Form2 из списка AutoCreate в список Available для рационального использования памяти и ресурсов.
5. Преобразуйте исходный файл проекта. Для этого чтобы открыть файл проекта выполните команду Project → View Sourсe и измените операторы между begin и end следующим образом: 
Form2:= TForm2.Create(Application);
{ Этот оператор создает объект формы заставки и присваивает его адрес переменной Form2, которая определена в программном модуле заставки }

Form2.Show;
Form2.Update;
{ Отображение объекта из памяти на экране и обновление его содержимого }

Application.CreateForm(TForm1,Form1);
Form2.Hide;
Form2.Free;
{ Скрытие формы заставки и освобождение занимаемой ею памяти }

Application.Run;
6. Для того, чтобы заставка оставалась на экране несколько секунд, для обработчика события OnCreate главной формы Form1 добавьте следующие операторы: 
CurrentTime:= GetTickCount div 1000;
{ Процедура CurrentTime возвращает время работы Windows в миллисекундах}

while((GetTickCount div 1000) < (CurrentTime + 4)) do;
{ Организация паузы в 4 секунды}
Объявите переменную CurrentTime типа longint в разделе var текущего модуля.
7. Поместите на форму заставки компонент Image из закладки Additional палитры компонентов. Вызовите встроенный редактор свойства Picture. Щелкнув по кнопке Load, выберите файл с картинкой для загрузки картинки в окно Picture Editor. (Можно загрузить стандартные картинки C:\Program Files\Common Files\Borland Shared\Images\…). Для того, чтобы растровое изображение внутри объекта Image1 занимало всю клиентную область, требуется изменить значение свойства Strech образа на True.
8. Поместите на форму заставки справа и снизу от рисунка два компонента Label из закладки Standard палитры компонентов. Отобразите на них информацию об авторе приложения и название приложения, используя различный размер, цвет и начертание шрифта.
9. Запустите приложение и проверьте его работу.
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Создание таймера
1. Добавьте к проекту новую форму Form3. Переместите Form3 из списка AutoCreate в список Available для рационального использования памяти и ресурсов.
2. Измените границы окна у Form3, сделайте их невидимыми, уберите значки максимизации, минимизации, системного меню.
3. Поместите на форму Form3 компонент Label, свойству Caption этого компонента присвойте значение 00:00:00. Выберите для своих часов шрифт, размер и стиль.
4. Преобразуйте исходный файл проекта. Для этого выполните команду Project → View Sourсe и добавьте перед строкой Application.Run операторы
Form3:=TForm3.Create(Application);
Form3.Show;
Form3.Update;
5. Поместите на форму Form3 компонент Timer из закладки System. В обработчик события OnTimer объекта Тimer1 добавьте следующую строку: 
Label1.Caption:=TimeToStr(Time);
{ TimeToStr преобразует текущее время в строку }
6. Для события OnCreate формы Form3 выберите обработчик Timer1Timer, который был создан для компонента Timer1. Тогда текущее время будет записано в метку до появления окна.
7. Для формы Form3 установите свойство FormStyle равным fsStayOnTop для того, чтобы часы были расположены всё время поверх других окон. Кроме того, установите свойство Visible в True.
8. Запустите приложение и проверьте его работу.
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Контрольные вопросы
1. Поясните назначение и основные свойства и события компонентов формы приложения. 
2. Поясните тексты методов приложения. 
3. В каком свойстве содержится заголовок формы? 
4. Назовите возможные значения свойства BorderStyle. Поясните их смысл. 
5. Для чего используется свойство BorderIcons? 
6. На что влияет свойство Formstyle? 
7. Когда совершается событие OnTimer объекта Тimer?
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